首页 > 技术文章 > ZOJ 1041 Transmitters

CKboss 2013-07-10 00:57 原文


Transmitters

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Problem Description
In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations.

ZOJ 1041 Transmitters - qhn999 - 码代码的猿猿

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter.

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle. 

Example input:

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5


Example output:

3
4
4

 

Source
Mid-Central USA 2001
 



用向量叉积判断是否在同一个半圆内



#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;

const double eps=1e-6;

struct Node
{
    int x,y;
}p[200];

int X,Y;
double R;

int ooxx(Node a,Node b)
{
    return a.x*b.y-b.x*a.y;
}

int main()
{
while(scanf("%d%d%lf",&X,&Y,&R)!=EOF)
{
    if(R<eps)  break;
    int n;
    scanf("%d",&n);
    int cnt=0;
    for(int i=0;i<n;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        x=x-X; y=y-Y;
        double distan=sqrt(x*x+y*y);
        if(R-distan>eps||R==distan)
        {
            p[cnt].x=x;
            p[cnt].y=y;
            cnt++;
        }
    }

    int ans=0;

    for(int i=0;i<cnt;i++)
    {
        int maxn=1;
        for(int j=0;j<cnt;j++)
        {
            if(i==j) continue;
            if(ooxx(p,p[j])>=0)
            {
                maxn++;
            }
        }
        ans=max(ans,maxn);
    }
    printf("%d\n",ans);
}

    return 0;
}


推荐阅读