首页 > 技术文章 > P1095 解码PAT准考证

daker-code 2020-02-16 14:31 原文

1095 解码PAT准考证 (25分)
 

PAT 准考证号由 4 部分组成:

  • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
  • 第 2~4 位是考场编号,范围从 101 到 999;
  • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
  • 最后 11~13 位是考生编号,范围从 000 到 999。

现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

输入格式:

输入首先在一行中给出两个正整数 N(≤)和 M(≤),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [ 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

  • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
  • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
  • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

输出格式:

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

  • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
  • 类型 为 2 的指令,按 人数 总分 的格式输出;
  • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

如果查询结果为空,则输出 NA

输入样例:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
 

输出样例:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

 

  终于啊,到了最后一题,拖了这么久终于要写完了,内心有些小激动,言归正传。

这道题目没有什么太大难度,即使得不了满分也能拿到多半成绩。题目相当于三个小任务,逐个击破即可。

我对每个任务编写了一个函数

任务1:

//某指定等级下非升序的排名
void instruction1(int times, Info **stu, int N)
{
    int flags = 1;
    char rank[2];
    scanf("%1s", rank);
    printf("Case %d: 1 %c\n", times + 1, rank[0]);

    for (int i = 0; i < N; i++)
    {
        if (stu[i]->rank[0] == rank[0])
        {
            flags = 0;
            printf("%c%03d%06d%03d %d\n", stu[i]->rank[0], stu[i]->room, stu[i]->date, stu[i]->id, stu[i]->score);
        }
    }
    if (flags)
    {
        printf("NA\n");
    }
}

 

任务2:

//某指定考场的考生人数和总分统计
void instruction2(int times, Info **stu, int N)
{
    int flags = 1;
    int room, count = 0, sum = 0;
    scanf("%d", &room);
    printf("Case %d: 2 %d\n", times + 1, room);

    for (int i = 0; i < N; i++)
    {
        if (stu[i]->room == room)
        {
            flags = 0;
            count++;
            sum += stu[i]->score;
        }
    }

    if (flags)
    {
        printf("NA\n");
    }
    else
    {
        printf("%d %d\n", count, sum);
    }
}

 

任务3:

//某指定日期的考生人数分考场统计输出
void instruction3(int times, Info **stu, int N)
{
    int flags = 1;
    int date, max = 0, room[1000] = {0};
    scanf("%d", &date);
    printf("Case %d: 3 %06d\n", times + 1, date);

    for (int i = 0; i < N; i++)
    {
        if (stu[i]->date == date)
        {
            flags = 0;
            room[stu[i]->room]++;
            if (max < room[stu[i]->room])
            {
                max = room[stu[i]->room];
            }
        }
    }

    if (flags)
    {
        printf("NA\n");
    }
    else
    { //计数排序缺点,个数超过1后逆序输出比较浪费时间
        //但是是平均时间复杂度为O(n)级输出
        //如果采用qsort排序+直接排序,平均时间复杂度为O(n+nlogn)
        for (int i = max; i > 0; i--)
        {
            for (int j = 101; j < 1000; j++)
            {
                if (i == room[j])
                {
                    printf("%d %d\n", j, i);
                }
            }
        }
    }
}

 

排序我在输入完成就进行,PAT乙级里的结构体类型的题目大多都是考的很细,但是不难。注意细节,不断优化就可以AC。

 

代码有些长,折起来先

#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
/**
 * rank 0       bit :   T A B
 * room 1~3     bit :   101 ~ 999
 * Date 4~9     bit :   xx-xx-xx
 * ID   10~12   bit :   101 ~ 999
 * score
 * 需要排序先写cmp,j字典序列载入string
 */
typedef struct
{
    char str[14];
    char rank[2];
    int room;
    int date;
    int id;
    int score;
} Info;

void instruction1(int times, Info **stu, int N);
void instruction2(int times, Info **stu, int N);
void instruction3(int times, Info **stu, int N);
int cmp(const void *a, const void *b) { return (*(Info **)a)->score == (*(Info **)b)->score ? strcmp((*(Info **)a)->str, (*(Info **)b)->str) : (*(Info **)a)->score < (*(Info **)b)->score ? 1 : -1; }

int main(void)
{
    int N, M, type;
    scanf("%d %d", &N, &M);

    Info student[10000], *stu[10000];

    for (int i = 0; i < N; i++)
    {
        stu[i] = student + i;
        scanf("%s %d", stu[i]->str, &stu[i]->score);
        sscanf(stu[i]->str, "%1s%3d%6d%3d", stu[i]->rank, &stu[i]->room, &stu[i]->date, &stu[i]->id);
    }

    qsort(stu, N, sizeof(stu[0]), cmp);

    for (int i = 0; i < M; i++)
    {
        scanf("%d", &type);

        switch (type)
        {
        case 1:
            instruction1(i, stu, N);
            break;
        case 2:
            instruction2(i, stu, N);
            break;
        case 3:
            instruction3(i, stu, N);
            break;
        }
    }

    return 0;
}

//某指定等级下非升序的排名
void instruction1(int times, Info **stu, int N)
{
    int flags = 1;
    char rank[2];
    scanf("%1s", rank);
    printf("Case %d: 1 %c\n", times + 1, rank[0]);

    for (int i = 0; i < N; i++)
    {
        if (stu[i]->rank[0] == rank[0])
        {
            flags = 0;
            printf("%c%03d%06d%03d %d\n", stu[i]->rank[0], stu[i]->room, stu[i]->date, stu[i]->id, stu[i]->score);
        }
    }
    if (flags)
    {
        printf("NA\n");
    }
}

//某指定考场的考生人数和总分统计
void instruction2(int times, Info **stu, int N)
{
    int flags = 1;
    int room, count = 0, sum = 0;
    scanf("%d", &room);
    printf("Case %d: 2 %d\n", times + 1, room);

    for (int i = 0; i < N; i++)
    {
        if (stu[i]->room == room)
        {
            flags = 0;
            count++;
            sum += stu[i]->score;
        }
    }

    if (flags)
    {
        printf("NA\n");
    }
    else
    {
        printf("%d %d\n", count, sum);
    }
}

//某指定日期的考生人数分考场统计输出
void instruction3(int times, Info **stu, int N)
{
    int flags = 1;
    int date, max = 0, room[1000] = {0};
    scanf("%d", &date);
    printf("Case %d: 3 %06d\n", times + 1, date);

    for (int i = 0; i < N; i++)
    {
        if (stu[i]->date == date)
        {
            flags = 0;
            room[stu[i]->room]++;
            if (max < room[stu[i]->room])
            {
                max = room[stu[i]->room];
            }
        }
    }

    if (flags)
    {
        printf("NA\n");
    }
    else
    { //计数排序缺点,个数超过1后逆序输出比较浪费时间
        //但是是平均时间复杂度为O(n)级输出
        //如果采用qsort排序+直接排序,平均时间复杂度为O(n+nlogn)
        for (int i = max; i > 0; i--)
        {
            for (int j = 101; j < 1000; j++)
            {
                if (i == room[j])
                {
                    printf("%d %d\n", j, i);
                }
            }
        }
    }
}
View Code

 

 

 

PAT不易,乙级AC!

推荐阅读