首页 > 技术文章 > HDU-1700 Points on Cycle

cancangood 2013-08-15 20:29 原文

这题的俩种方法都是看别人的代码,方法可以学习学习,要多看看。。

几何题用到向量。。

Points on Cycle

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1294    Accepted Submission(s): 455

Problem Description
There is a cycle with its center on the origin. Now give you a point on the cycle, you are to find out the other two points on it, to maximize the sum of the distance between each other you may assume that the radius of the cycle will not exceed 1000.
 
Input
There are T test cases, in each case there are 2 decimal number representing the coordinate of the given point.
 
Output
For each testcase you are supposed to output the coordinates of both of the unknow points by 3 decimal places of precision
Alway output the lower one first(with a smaller Y-coordinate value), if they have the same Y value output the one with a smaller X.
NOTE
when output, if the absolute difference between the coordinate values X1 and X2 is smaller than 0.0005, we assume they are equal.
 
Sample Input
2 1.500 2.000 563.585 1.251
 
Sample Output
0.982 -2.299 -2.482 0.299 -280.709 -488.704 -282.876 487.453
 
Source
 
//题意:一个以原点为中心的圆,告诉你圆上的一个点,求与另外的两个点组成的三角形的周长最长的两点作标。
//根据几何知识,知道圆内等边三角形的周长最长。所以题目转化为求已知一个点的圆内接等边三角形的另两点作标。
//思路:设P(x,y),一个方程是pow(x,2)+pow(y,2)=pow(r,2);另一个方程是根据向量知识,向量的夹角公式得到方程。
//因为圆心角夹角为120度,已知一个向量(即一个点作标),所以COS(2PI/3)=a*b/|a|*|b|;(a,b为向量);
//已知角和a向量,就可求b向量b(x,y).由方程组可求得(x,y);最后得到的是一元二次方程组,可得到两个解,即为两个点的作标。
//代码如下:
#include <stdio.h>  
#include <math.h>  
#define PI 3.1415926  
int main()  
{  
    double x,y,x1,y1,x2,y2,cosx,a,b,c,r,delta;  
    int t;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%lf%lf",&x,&y);  
        r=sqrt(x*x+y*y);  
        a=r*r;  
        b=r*r*y;  
        c=r*r*r*r/4-x*x*r*r;  
        delta=b*b-4*a*c;  
        y1=(-1*b-sqrt(delta))/(2*a);  
        y2=(-1*b+sqrt(delta))/(2*a);  
        if(x==0)  
        {  
            x1=-sqrt(r*r-y1*y1);  
            x2=sqrt(r*r-y2*y2);  
        }  
        else  
        {  
            x1=(-1*r*r/2-y*y1)/x;  
            x2=(-1*r*r/2-y*y2)/x;  
        }  
        printf("%.3lf %.3lf %.3lf %.3lf\n",x1,y1,x2,y2);  
    }  
    return 0; 
}
/*已知一个以(0,0)为圆心的圆和圆上的一点(x0,y0)求圆上的另外两点(x1,y1,)(x2,y2),使得向量(x1,y1)(x2,y2)和(x0,y0)各个向量两两之间夹角为120度
此题主要用到向量的叉乘和点乘列出两个二元一次方程组
1.
(x0,y0)X (x1,y1) = sin(120)*R^2 (r为圆的半径)
(x0,y0) * (x1,y1) = cos(120)*R^2
结果为:
x1=b*x0-a*y0; a=sin120
y1=b*y0+a*x0; b=cos120;
2.
(x0,y0)X (x2,y2) = -sin(120)*R^2 (r为圆的半径)
(x0,y0) * (x2,y2) = cos(120)*R^2
注:题目假设向量(x1,y1)在向量(x0,y0)逆时针方向 故叉乘结果为正值
(x2,y2)于(x0,y0)的顺时针方向 故叉乘结果为负值*/
#include <stdio.h>
#include <math.h>
int main()
 {
double a,b,sinx,cosx,x0,y0,x1,y1,x2,y2;
int t;
a=sinx=sqrt(3.0)/2;
b=cosx=-0.5;
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf",&x0,&y0);
x1=b*x0-a*y0;
y1=b*y0+a*x0;
x2=b*x0+a*y0;
y2=b*y0-a*x0;
if(y1<y2||((abs(y1-y2)<0.005)&&x1<x2))
{
printf("%.3lf %.3lf %.3lf %.3lf\n",x1,y1,x2,y2);
}
else
  printf("%.3lf %.3lf %.3lf %.3lf\n",x2,y2,x1,y1);
}
return 0;
}
 

 

推荐阅读