首页 > 技术文章 > poj 2063 Investmen 完全背包

superxuezhazha 2016-08-07 18:22 原文

这个题的想法不难,两个点:
1 是完全背包
2 是考虑/1000,降低复杂度
 
但是提交的时候反复的wa,最后找问题原来是dp开小了,可是dp本来开1005,后来开到100030过了。哎,如果没有时间计算
dp的长度的话,就往大了开,血的教训。
 
 
Investment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10087   Accepted: 3539

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
Value Annual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

Source

 
 
#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
const int maxx = 105;
//long long dp[maxx][maxx];
int  dp[100030];
int  bag;
int  w[maxx],v[maxx];
int kind;
int year;
int  get()
{
    memset(dp,0,sizeof(dp));
   /* for(int i=1;i<=kind;i++)
    {
        for(int j=0;j<=bag;j++)
        {
            for(int k=0;k*w[i]<=j;k++)
            {
                dp[i][j]=max(dp[i][j],dp[i-1][j-w[i]*k]+v[i]*k);
            }

        }
    }
    bag=dp[kind][bag];
    return bag;*/
    for(int i=1;i<=kind;i++)
    {
        for(int j=w[i];j<=bag;j++)
            {
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
            }
    }
    return dp[bag];
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int ans=0;
        scanf("%d%d",&bag,&year);
        scanf("%d",&kind);
        ans=bag;
        bag/=1000;
        for(int i=1;i<=kind;i++)
        {
            scanf("%d%d",&w[i],&v[i]);
            w[i]/=1000;
        }
        for(int k=0;k<year;k++)
        {
            ans+=get();
            bag=(ans/1000);

        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

推荐阅读