首页 > 技术文章 > HDU1074 Max Sum Plus Plus

Radium1209 2018-11-13 17:46 原文

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38720    Accepted Submission(s): 13890

 

Problem Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

 

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.

 

Output

Output the maximal summation described above in one line.

 

Sample Input

1 3 1 2 3

2 6 -1 4 -2 3 -2 3

 

Sample Output

6 8

 

Hint

Huge input, scanf and dynamic programming is recommended.

 

 

Source

HDU1074

 

题意:给你n个数,求m个不相交的连续子序列和最大

 

题解:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
const int inf=0x3f3f3f3f;
const int MAXN=1000000;
using namespace std;

int a[MAXN+5],pre[MAXN+5],now[MAXN+5];

int main()
{
	int n,m,maxx;
	while(cin >> m >> n)
	{
		memset(pre,0,sizeof(pre));
		memset(now,0,sizeof(now));
		for (int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for (int i=1;i<=m;i++)
		{
			maxx=-inf;
			for (int j=i;j<=n;j++)
			{
				now[j]=max(now[j-1]+a[j],pre[j-1]+a[j]);
				pre[j-1]=maxx;
				maxx=max(maxx,now[j]);
			}
		}
		printf("%d\n",maxx);
	}
	return 0;
}

 

推荐阅读