首页 > 技术文章 > hdoj1005--Number Sequence

xueda120 2014-03-01 01:20 原文

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 
Output
For each test case, print the value of f(n) on a single line.
 
Sample Input
1 1 3
1 2 10
0 0 0
 
Sample Output
2
5
 
序列是循环的,以49为周期,具体原因不明
#include<iostream>
using namespace std;

void solve()
{
    int A, B, n;
    while(cin>>A>>B>>n && (A || B || n)) {
        int a[2] = {1, 1};
        for(int i = 0; i < (n %49 - 1) / 2; i++) {
            a[0] = (A * a[1] + B * a[0]) % 7;
            a[1] = (A * a[0] + B * a[1]) % 7;
        }
        if(n % 2) {
            cout<<a[0]<<endl;
        } else {
            cout<<a[1]<<endl;
        }
    }
}

int main()
{
    solve();
    return 0;
}

 

推荐阅读