首页 > 技术文章 > HDU-1260_Tickets

luoxiaoyi 2018-10-22 14:57 原文

Tickets

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

  1. An integer K(1<=K<=2000) representing the total number of people;
  2. K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
  3. (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

题意:有t组输入,每组输入有三行,有n个人买票,第二行表示这n个人买票的时间,第三行表示这个人跟前一个人一起买票的时间。
题解:用dp[i]表示第几个人买票,转移方程dp[i] = min(dp[i-1]+这个人买票的时间,dp[i-2]+这个人跟前一个人一起买票的时间)
其中dp[1] = a[1]。
这道题的数据有点弱,下面两种输出都过了

        if(h>=12)
        {
            h -= 12;
            printf("%02d:%02d:%02d pm\n",h,m,s);
        }
        else
        {
            printf("%02d:%02d:%02d am\n",h,m,s);
        }
        if(h>=12)
        {
            printf("%02d:%02d:%02d pm\n",h,m,s);
        }
        else
        {
            printf("%02d:%02d:%02d am\n",h,m,s);
        }
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int t,n,i,dp[2050],a[2050],b[2050];
    cin>>t;
    while(t--)
    {
        cin>>n;
        dp[0] = 0;
        for(i=1;i<=n;i++)
            cin>>a[i];
        for(i=1;i<=n-1;i++)
            cin>>b[i];
        dp[1] = a[1];
        for(i=2;i<=n;i++)
            dp[i] = min(dp[i-1] + a[i],dp[i-2] + b[i-1]);
        int h,m,s;
        h = dp[n] / 3600 + 8;
        m = dp[n] / 60 % 60;
        s = dp[n] % 60;
        if(h>=24)
            h %= 24;
        if(h>=12)
        {
            h -= 12;
            printf("%02d:%02d:%02d pm\n",h,m,s);
        }
        else
        {
            printf("%02d:%02d:%02d am\n",h,m,s);
        }
    }
    return 0;
}

推荐阅读