首页 > 技术文章 > 【POJ 3140】 Contestants Division(树型dp)

lytwajue 2017-08-02 13:19 原文

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9121   Accepted: 2623

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

Source


发现训练计划树dp的难度是递减的……不要说什么做多了熟练了。。真的是递减的。。这个非常适合入门……结果就被垫底了,。可能不是有意的……但像我这样的喜欢从上往下刷的………………

题目大意:几个学校间有连接,而且保证是树状连接,如今要在某条线路(树边)上搭载系统,为了降低负荷,要让系统两边的学生数量差值尽量少
dfs的时候能够遍历到全部的边。这样每条边的孩子所在的子树的全部节点权值(学生数)非常easy求出,然后用总学生数减去它。就是树边的还有一边的全部学生数了。

代码例如以下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

struct Edge
{
	int v,next;
};

Edge eg[2333333];
int head[233333];
int val[233333];
LL dp[233333];
int n,m;
LL sum,mn;

void dfs(int u,int pre)
{
	dp[u] = val[u];
	for(int i = head[u]; i != -1; i = eg[i].next)
	{
		int v = eg[i].v;
		if(v == pre) continue;
		dfs(v,u);
		LL tmp = sum-dp[v]*2;
		if(tmp < 0) tmp = -tmp;
		if(mn == -1) mn = tmp;
		else mn = min(mn,tmp);
		dp[u] += dp[v];
	}
}

int main()
{
	//fread();
	//fwrite();

	int u,v,z = 1;

	while(~scanf("%d%d",&n,&m) && (n+m))
	{
		sum = 0;
		for(int i = 1; i <= n; ++i)
		{
			scanf("%d",&val[i]);
			sum += val[i];
		}

		int tp = 0;
		memset(head,-1,sizeof(head));
		for(int i = 0; i < m; ++i)
		{
			scanf("%d%d",&u,&v);
			eg[tp].v = v;
			eg[tp].next = head[u];
			head[u] = tp++;
			eg[tp].v = u;
			eg[tp].next = head[v];
			head[v] = tp++;
		}

		mn = -1;
		dfs(1,1);
		printf("Case %d: %lld\n",z++,mn);
	}

	return 0;
}





推荐阅读