首页 > 技术文章 > hdu 4283 区间dp

Przz 2016-08-21 09:52 原文

You Are the One

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3348    Accepted Submission(s): 1524


Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 

 

Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 

 

Output
  For each test case, output the least summary of unhappiness .
 

 

Sample Input
2   
5
1 2 3 4 5
5
5 4 3 2 2
 

 

Sample Output
Case #1: 20
Case #2: 24

 

/*
hdu 4283 区间dp

problem:
给定一个序列,序列内的人有值Di,然后将这个序列的人进栈,第i个人如果是第k个出栈,那么最后的总值增加
Di*(k-1), 求一个出栈序列使得总值最小。

solve:
对于[1,n]而言,如果1是第k个出栈,那么[2,k]肯定比1先出栈,[k+1,n]肯定比1后出栈.于是求能划分出子区间
所以可以用区间DP解决,只是在合并的时候需要处理

study:http://blog.csdn.net/woshi250hua/article/details/7969225
2016-08-17 16:57:17
*/
#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <vector>
#include <map>
#define lson  i<<1
#define rson  i<<1|1
#define ll long long
#define key_val ch[ch[root][1]][0]
using namespace std;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
int dp[105][105];
int a[maxn];
int sum[maxn];

int main()
{
//    freopen("in.txt","r",stdin);
    int T,cas = 1;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        sum[0] = 0;
        printf("Case #%d: ",cas++);
        scanf("%d",&n);
        for(int i = 1;i <= n;i++)
        {
            for(int j = i + 1;j <= n;j++)
                dp[i][j] = inf;
        }
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&a[i]);
            sum[i] = sum[i-1] + a[i];
//            cout << a[i] << endl;
        }

        for(int lgd = 1; lgd <  n; lgd++)
        {
            for(int i = 1; i + lgd <= n; i++)
            {
                int j = i + lgd;
                for(int k = i; k <= j; k++)
                {
                    int tp = (k-i)*a[i];
                    tp += dp[i+1][k] + dp[k+1][j];
                    tp += (k-i+1)*(sum[j] - sum[k]);
                    dp[i][j] = min(dp[i][j],tp);
                }
            }
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

  

推荐阅读